Running a report terminates Service Accent unexpectedly

Article ID: 070423110226 - Last Review: 23 April 2007 by jasonl - Revision: 1 - Views: 4515


Symptom
Running a report from within Service Accent produces a Windows error message similar to:

This program has generated errors and will be shut down


Examination of the Windows Event Log shows that the module W3MIF.DLL or similar caused the error. Clicking on Help | About Service Accent shows that Service Accent Service Pack 4 is not installed.


Cause
Crystal Reports uses database drivers to abstract itself from the database layer which could, under certain circumstances, cause a conflict with the Pervasive.SQL native database drivers when using the Crystal Reports 10 components (installed with Service Accent Service Pack 2).


Solution
Download and install Service Accent Service Pack 4b (or a later version of Service Pack 4) which installs the Crystal Report 11 run-time components. This has shown to fix the problem described above.


 Download this item


 
 Related articles

Attempting to run a report returns status 525
Can not find database dll error 532 message when running a report
How to save your reports after applying an update
How to update your own reports to the latest version of Service Accent
Message 'Could not start the Crystal Reports engine'
Reports run very slowly under Windows Vista with Pervasive.SQL V9
Running a report returns error 507 or 709
Unexpected termination when running a report

 Additional articles from the white papers

Service Accent - Report reference
Service Accent - Adding client reports



For additional resources and information, you can go to the Service Accent Support Centre

Click here to go to the Service Accent Support Centre



Copyright © 2003-2020 Vantage Computing Ltd. All rights reserved. The information contained on this web site is correct as of its publication date.